Installation in nVidia Proprietary Drivers in Week1 (archived)

InstructionsLink to the installation instructions
InstallationDetailed information on the testcase
Testcase (Report an issue with this testcase)
This is a legacy testcase, content is only available here: http://testcases.qa.ubuntu.com/Hardware/X/ProprietaryDrivers#Installation
ReporterLast updateBugsComment
Failedxdatap12010-02-17 16:54
Pressing causes X to freeze (#516412)
In: plymouth (Ubuntu)
Status: Fix Released
Importance: High
Assignee: None
1 reports, 142 comments, 41 subscribers, 18 duplicates
516412
Ensure that X.org startup failure displays (EE) messages to the user (#522588)
In: nvidia-graphics-drivers (Ubuntu)
Status: Triaged
Importance: Medium
Assignee: Canonical X.org
1 reports, 12 comments, 3 subscribers, 0 duplicates
522588

Installing proprietary drivers (Case ID xpr-001) it doesnt works because the graphic card need a "NoPowerConnectorCheck" option on screen section. Also failed the Fallback mode, I had to switch to a textual terminal to fix the problem.

ReporterLast updateBugsComment
PassedWallETester2010-02-22 00:20
PassedLuis_Ferreira2010-02-21 18:07
Passeddanielbell2010-02-20 11:52

Worked fine.
Before no proprietary drivers were installed there was no /etc/X11/xorg.conf file.
Installed recommended driver.
/etc/X11/xorg.conf appears, and notes: module: "glx" and driver: "nvidia".

PassedPRab2010-02-19 01:33

When I tried to login after the reboot, it looked like showed 2 character cell graphics then sent me back to the login screen. I tried to login again and it worked.

Passedgabox2010-02-18 14:23
Passedboran2010-02-17 18:14

Installed as per email instructions.

Passedjmoronat2010-02-17 14:42

jockey-gtk says "Activated but not in use", but it is in use (confirmed by seeing compiz effects).

Passedssweeny2010-02-17 03:05
Passedd3mia72010-02-17 02:07

Passed after reboot with all updates installed.

PassedSoftwareExplorer2010-02-17 01:07

Worked fine. I used the suggested driver.

PassedFoH2010-02-16 11:16
Pressing causes X to freeze (#516412)
(master bug of duplicate: 519505)
In: plymouth (Ubuntu)
Status: Fix Released
Importance: High
Assignee: None
1 reports, 142 comments, 41 subscribers, 18 duplicates
519505

I got around the "Enter hang bug" by logging out and then in again. Step 6 in the instructions doesn't produce any output, but the driver is loaded. However, jockey-gtk says "Activated but not in use" even though it appears to be in use.

Passedyasaswi.lakkaraju2010-02-16 10:21

This test pass the second time it was tested. The first time the Nvidia HW was not detected, but it was able to detect eh card and install the appropriate driver after I restarted the system

Passedramon.rocha2010-02-16 03:23

After working around some other bugs, I was able to successfully install and verify proper loading of the nvidia driver.

The behavior I was seeing seems identical to https://bugs.launchpad.net/bugs/396226

Passeddanbhfive2010-02-16 02:25
Passedcaseyjp2010-02-15 10:31
Passedfido2010-02-15 09:00
ReporterLast updateBugsComment
In Progresscharlie-tca2010-02-18 00:30
gnome-screensaver-gl-helper crashed with SIGSEGV in exit() (#508531)
(master bug of duplicate: 522267)
In: nvidia-graphics-drivers (Ubuntu)
Status: Invalid
Importance: Undecided
Assignee: None
1 reports, 7 comments, 8 subscribers, 5 duplicates
522267

Verified that there is a menu entry - "System -> Administration -> NVIDIA X Server Settings" after installing the hardware drivers and restarting once. I do have the message when checking under "System -> Administration -> Hardware Drivers", 'This driver is activated but not currently in use.' No desktop effects can be enabled. Restarted the system, tried again, can now activate the desktop effects in "System -> Preferences -> Appearances".

Add a test result

You need to be logged in to submit your test results.