Installation in ATI Proprietary Drivers in FakeCycle (archived)

InstructionsLink to the installation instructions
InstallationDetailed information on the testcase
Testcase (Report an issue with this testcase)
This is a legacy testcase, content is only available here: http://testcases.qa.ubuntu.com/Hardware/X/ProprietaryDrivers#Installation
ReporterLast updateBugsComment
Faileddarkmatter2010-02-13 10:06
Does not support current Lucid kernel (2.6.32) or xserver (1.7) (#494699)
(master bug of duplicate: 519053)
In: fglrx-installer (Ubuntu)
Status: Fix Released
Importance: Critical
Assignee: Alberto Milone
1 reports, 92 comments, 42 subscribers, 10 duplicates
519053

Installation xpr-001

1. OK
2. OK (no xorg.conf)
3. OK
4. Fail - no proprietary driver identified
5. Fail - workaround instal by sudo aptitude install xorg-driver-fglrx complains about about broken xserver-xorg-core package

Test could not be finished.

Failedbenimnetz2010-02-09 15:10
jockey-gtk doesn't detect NVidia Video cards to install proprietary driver (#518067)
In: jockey (Ubuntu)
Status: Fix Released
Importance: High
Assignee: None
1 reports, 13 comments, 5 subscribers, 0 duplicates
518067

im not shure the bug number is 100% correct because the report is about nvidia cards and i have an ati

1) installs fine with opensource drivers
2) xorg.conf is absend
4) no proprietary driver is found for my hardware

FailedYann Sionneau2010-02-08 22:48
Does not support current Lucid kernel (2.6.32) or xserver (1.7) (#494699)
(master bug of duplicate: 519053)
In: fglrx-installer (Ubuntu)
Status: Fix Released
Importance: Critical
Assignee: Alberto Milone
1 reports, 92 comments, 42 subscribers, 10 duplicates
519053

Installation

4°) Driver non detected by "Hardware Drivers"
6°)

yann@tablet:~$ find /lib/modules/ -type f -ls -iname '*.ko' | grep -E "/nvidia.ko|/fglrx.ko"
394297 3160 -rw-r--r-- 1 root root 3235248 févr. 8 17:06 /lib/modules/2.6.32-12-generic/updates/dkms/fglrx.ko

timestamp is OK.

7°) no /etc/X11/xorg.conf

9°) GUI comes up

10°) grep -E "LoadModule:.*\"nvidia|fglrx\"" /var/log/Xorg.0.log

this returns nothing, but i have this in the Xorg.0.log :

yann@tablet:~$ cat /var/log/Xorg.0.log | grep fglr
(II) Loading sub module "fglrxdrm"
(II) LoadModule: "fglrxdrm"
(II) Loading /usr/lib/xorg/modules/linux/libfglrxdrm.so
(II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."

and it loaded the module

yann@tablet:~$ lsmod | grep fglr
fglrx 2207986 0

FailedLibertyZero2010-02-06 23:49
Does not support current Lucid kernel (2.6.32) or xserver (1.7) (#494699)
In: fglrx-installer (Ubuntu)
Status: Fix Released
Importance: Critical
Assignee: Alberto Milone
1 reports, 92 comments, 41 subscribers, 10 duplicates
494699

Test

ReporterLast updateBugsComment
PassedDennis Beekman2010-02-08 09:51

Seems to install fine, have to test it further (test)

ReporterLast updateBugsComment
In Progressindus2010-02-05 12:07

Installs fine,but need to run more tests.This is a fake comment please ignore.

Add a test result

You need to be logged in to submit your test results.